Hello There, Guest! Register

SSL hiccups
Pleeb Offline
Owner
Forum Administrators

Posts: 770
Threads: 62
Joined: May 2012
#1
 
SSL hiccups
Hello tulpa.info,

You might be receiving SSL warnings or notice other weird things happening; long story short, our certificate expired; I've renewed it, and I'm working on getting everything back on track.
08-05-2015, 01:32 AM
Website Find Reply
Pleeb Offline
Owner
Forum Administrators

Posts: 770
Threads: 62
Joined: May 2012
#2
 
RE: SSL hiccups
HA! I fixed it!

Basically, the certificate expired so I decided to generate a new certificate. However, I was thinking about it, and decided to try something else. We used to use Cloudflare for the longest time, and have always loved it because it speeds up the site and saves on bandwidth. Unfortunately, Cloudflare doesn't play nice with SSL unless things are configured a specific way.

To make a long story short, cloudflare didn't see the SSL, and tried to redirect it to https. MyBB thought it was supposed to be https, so it tried redirecting itself to https... The end result was a 301 redirect from https://community.tulpa.info to https://community.tulpa.info For all you non-tech guys out there, it means that we got thrown into an infinite loop that crashed everything. I found the solution on this site and modified the GoogleSEO plugin accordingly.

Now we have SSL and Cloudflare!
08-05-2015, 02:20 AM
Website Find Reply
sushi Offline
Member
Registered

Posts: 874
Threads: 14
Joined: May 2014
#3
 
RE: SSL hiccups
I've had some weird things happening these past few days. It's still going on. Not sure if this is the same issue or not though.

Anyway, well, let me take a screenshot. The theme isn't displaying correctly, which is just mildly annoying. The more inconvenient thing is that periodically my browser gives me the error message: "Unable to complete secure transaction", and I have to manually change "https" to "http" to get the page to load.

This seems to only happen with Opera -- Firefox and Explorer (I think) display the site correctly. I think the default browser on my Android S4 was giving me trouble earlier, but it seems to be working flawlessly now, so perhaps I'm mistaken.

"Some things have to be believed to be seen." - Ralph Hodgson
08-07-2015, 11:44 PM
Find Reply
Pleeb Offline
Owner
Forum Administrators

Posts: 770
Threads: 62
Joined: May 2012
#4
 
RE: SSL hiccups
(08-07-2015, 11:44 PM)sushi Wrote: I've had some weird things happening these past few days. It's still going on. Not sure if this is the same issue or not though.

Anyway, well, let me take a screenshot. The theme isn't displaying correctly, which is just mildly annoying. The more inconvenient thing is that periodically my browser gives me the error message: "Unable to complete secure transaction", and I have to manually change "https" to "http" to get the page to load.

This seems to only happen with Opera -- Firefox and Explorer (I think) display the site correctly. I think the default browser on my Android S4 was giving me trouble earlier, but it seems to be working flawlessly now, so perhaps I'm mistaken.
I think it seems to be a cached thing, in which case it should resolve itself soon. I just installed Opera and tried it on my computer, and it looked normal. Try clearing your browser cache and see if it fixes the problem.
(This post was last modified: 08-08-2015, 12:34 AM by Pleeb.)
08-08-2015, 12:33 AM
Website Find Reply
sushi Offline
Member
Registered

Posts: 874
Threads: 14
Joined: May 2014
#5
 
RE: SSL hiccups
Browser cache doesn't seem to be doing anything for it. It must be because I'm on an old version of Opera: 11.62.

"Some things have to be believed to be seen." - Ralph Hodgson
08-08-2015, 03:40 PM
Find Reply
Chupi Offline
Goopi on IRC
Forum Administrators

Posts: 1,500
Threads: 39
Joined: Apr 2012
#6
 
RE: SSL hiccups
Does a newer browser work for you? And does Opera 11.62 mess up other sites in a similar way sometimes? If not, I blame Cloudflare -- It's either mis-caching something or a connection isn't getting through.
08-10-2015, 06:53 PM
Website Find Reply
sushi Offline
Member
Registered

Posts: 874
Threads: 14
Joined: May 2014
#7
 
RE: SSL hiccups
This is the only site that had given me that trouble, and only this last week or so. But yeah, if I'm the only one having trouble, I can get a new browser.

"Some things have to be believed to be seen." - Ralph Hodgson
08-10-2015, 07:13 PM
Find Reply
The Commander Offline
The Blood Knight
Registered

Posts: 64
Threads: 7
Joined: Aug 2013
#8
 
RE: SSL hiccups
This is what I'm staring at.

https://gyazo.com/9a965858fe1f2baa230bfa7bdf479ce8

https://gyazo.com/866e684f48d0d2284e97d5138f8fac87

Don't think that's normal...

Current: Rainbow Dash & Ruby the Dolphin

LINK to the story of my Wonderland.

The story is the product of 16 years of stress, tension, etc, and is uncensored, read at your own risk.
08-13-2015, 05:06 AM
Website Find Reply
sushi Offline
Member
Registered

Posts: 874
Threads: 14
Joined: May 2014
#9
 
RE: SSL hiccups
That's the same as for me. What version of Chrome is that?

"Some things have to be believed to be seen." - Ralph Hodgson
08-13-2015, 12:18 PM
Find Reply
The Commander Offline
The Blood Knight
Registered

Posts: 64
Threads: 7
Joined: Aug 2013
#10
 
RE: SSL hiccups
How do you check?

Current: Rainbow Dash & Ruby the Dolphin

LINK to the story of my Wonderland.

The story is the product of 16 years of stress, tension, etc, and is uncensored, read at your own risk.
08-13-2015, 06:55 PM
Website Find Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | Tulpa.Info | Return to Top | Return to Content | Mobile Version | RSS Syndication