Tewi

Preview Post Auto-Scrolling

Recommended Posts

Since the update to the forum format introducing the account switcher, whenever a post is large enough that in the preview interface the text box is pushed off screen, the page will auto scroll back down to the text box.

 

That's completely redundant and driving me insane. I found out just now you can prevent that by unchecking "Show the MyCode formatting options on the posting pages." option in Profile Options. This completely disables the bar with formatting options such as text size and italicizing. Unfortunately, it also shrinks the box horizontally, causing it to be much less representative of what the final post will look like mid-writing.

 

That's not the end of the world, but I'd prefer if it just worked as it used to. The auto-scrolling has been encouraging me to post without proof-reading and then quickly read over and edit the post if need be, which is pretty annoying in itself.

 

Also, this only seems to be the case when "Put the editor in source mode by default" is checked. But I pity anyone who doesn't have it so - in testing how it worked and attempting to continue writing my post in non-source mode, copy-pasting that 'Put the editor in source mode by default' lagged the box and pasted in invisible, small (white when previewed) text. I also have them displaying in classic mode. I have no idea if that's what everyone else uses, but I'm not changing it two years later.


Hi, I'm Tewi, one of Luminesce's tulpas. I often switch to take care of things for the others.

All I want is a simple, peaceful life. With my family.

Our Ask thread: https://community.tulpa.info/thread-ask-lumi-s-tulpas

Share this post


Link to post
Share on other sites

Having looked at this for a few minutes I'm pretty sure why this is happening. Browsers tend to scroll down to the text cursor if it's not already on the screen. It seems that the behaviour (in some browsers) for the posting configurations you describe (and not the others) when you hit 'Preview' is that the text cursor is placed at the end of the post input box, which for long posts (and narrow screens) is typically off the screen.

 

I don't have access to modify what's being served, unfortunately, but I can roughly guess that this behaviour is unintentional, and a fix would probably entail messing with the various text boxes and figuring out why some get auto-focused and some don't. And I can't see a way to disable scroll-to-cursor in Chrome at least, so that's the best bet. Note that when the account switcher was introduced, MyBB itself was also updated, along with lots of other things, so it's probably just coincidental there.

 

You should be able to resize the post input box's width and height by dragging the bottom right corner, if width is what you're after when previewing.

Share this post


Link to post
Share on other sites

Oh, yeah, I just didn't know what to call the MyBB update so I refer to it as the account switcher update. The account switcher works fine. Though in many places where one would be linked to a profile it instead switches our accounts.

 

Anyways, there's a little more than that, but it's not a big problem. Trying to write this post was a huge pain. Every time I hit Preview it would screw up all of my text in pretty strange ways, for example filling in #x# with some arbitrary numbers instead. It also added extra img tags. And this surely bugs no one but us, but quotes automatically take up two extra lines, so we always backspace them to put them on one line (even if it runs over anyways). Hitting preview now resets that and I have to do it again.

 

It's a good thing we're not OCD.


Hi, I'm Tewi, one of Luminesce's tulpas. I often switch to take care of things for the others.

All I want is a simple, peaceful life. With my family.

Our Ask thread: https://community.tulpa.info/thread-ask-lumi-s-tulpas

Share this post


Link to post
Share on other sites

Hey, after all these years, the newest forum update seems to have finally fixed this. Sheesh!

 

Every time we post in our Dreaming thread, we change the post "Title" in the post preview page, but the auto-scrolling would always move our cursor down and make us backspace something in the post rather than the RE: at the top. That's finally no longer a thing, four freakin' years later.


Nevermind. It's only fixed "sometimes", apparently.

Hi! I'm Lumi, host of Reisen, Tewi, Flandre and Lucilyn.

Everyone deserves to love and be loved. It's human nature.

My tulpas and I have a Q&A thread, which was the first (and largest) of its kind. Feel free to ask us stuff.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.