Sign in to follow this  
imahaxor

CloudFlare: Website is offline

Recommended Posts

For the past couple of days, I have been unable to access the forums. Every other link on tulpa.info works fine, but for some reason when I try to access the forums I get a CloudFlare error saying the page is offline. I'm able to post here now because I am using a proxy.

 

I'm not sure if this is a problem on my end or a problem with CloudFlare, but it would be awesome if I could get some help.


My Tulpa

And then it cuts to a scene where you're sitting in a padded cell.

 

Share this post


Link to post
Share on other sites

It means the server is offline. Cloudflare runs a cache of the site. When the server is not reachable, it serves its cached copy. This only works with the rest of the site, where the pages are static. On the forum, pages are dynamic and not the same page is served to everyone every time (replies get added, who's logged in, list of users viewing the thread changes, etc.) -- so it can't reasonably cache the forum.

 

Typically it means that too many requests are happening at the same time, so the server couldn't respond to yours in a reasonable time. A more powerful server would make this happen a lot less but that costs money we don't have. So, wait a minute and F5 it.


Lyra: human female, ~17

Evan: boy, ~14, was an Eevee

Anera: anime-style girl, ~12; Lyra made her

My blog :: Time expectations are bad (forcing time targets are good though)

Share this post


Link to post
Share on other sites

I'm having the same issue as well. However, why does a proxy allow me to access the forums without fail and not my own connection? Wouldn't they both timeout?


Share this post


Link to post
Share on other sites

I'm having the same issue as well. However, why does a proxy allow me to access the forums without fail and not my own connection? Wouldn't they both timeout?

 

This is exactly my issue as well. The rest of the site works fine; only the forums remain inaccessible. It's a persistent blockade that hasn't resolved itself at any point in weeks.

 

The fact that a proxy bypasses the message indicates another problem other than server traffic. I have no prior experience with Cloud Flare, so I can't speak for its functionality, but that seems to be the culprit.

Share this post


Link to post
Share on other sites

I'm having the same issue as well. However, why does a proxy allow me to access the forums without fail and not my own connection? Wouldn't they both timeout?

 

I'm not sure, but it's probably something to do with CloudFlare's CDN. Since it's a CDN, you connect to different servers depending on where you are. Depending on how these servers go about connecting to the tulpa.info server, one might succeed where another failed.


Lyra: human female, ~17

Evan: boy, ~14, was an Eevee

Anera: anime-style girl, ~12; Lyra made her

My blog :: Time expectations are bad (forcing time targets are good though)

Share this post


Link to post
Share on other sites

I'm happy to report that I can finally get on the forums now without the use of a proxy. I don't know if the problem just fixed itself or what, but thank you to whomever may have fixed it.


My Tulpa

And then it cuts to a scene where you're sitting in a padded cell.

 

Share this post


Link to post
Share on other sites

I'm happy to report that I can finally get on the forums now without the use of a proxy. I don't know if the problem just fixed itself or what, but thank you to whomever may have fixed it.

^This.

 

I was beginning to miss browsing this site.


Share this post


Link to post
Share on other sites

For the future, there is usually a button on a CloudFlare error page when it's unable to access the site. I'm not sure exactly how CloudFlare does things, but a lot of the time it doesn't seem to resolve itself for me unless I manually click the button to 'retry for a live version of this site'. If that doesn't fix it, it's the server that's down and not CloudFlare. Also, if you're in the UK, there can sometimes be problems with the link(s) between the UK and parts of the US - I've found occasionally that I can't access a site directly, but I can through one of my servers in the US.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.