Sign in to follow this  
Semi-Nomadic

"View New Posts" buggy

Recommended Posts

Apparently, the "view new posts" option only shows new threads and not all new posts. That, or it only works half the time, the other times returning an error which says it found no new posts (even though there are). What's up with that?

Share this post


Link to post
Share on other sites

it's showing threads with new posts - not new threads entirely

 

as for the later part of your post (saying no new posts) i'm inclined to believe you've already visited that page of the thread and it marked the posts as 'read' even if you haven't read them


Yukari (vocal), Arisa (vocal)

Don't look down.

Share this post


Link to post
Share on other sites

I've noticed this, too. Only works half the time. I just don't use it.

 

I've also noticed another bug on the forum, which is the subforum icons on the board index not updating properly when you just hit the back button after finishing reading a thread. You have to click on the subforum of the thread, and then click your way to the board index thereafter, before the subforum icons will stop showing as "unread." You can't just use the back button in your browser. No, refreshing doesn't help.

Share this post


Link to post
Share on other sites
I've noticed this, too. Only works half the time. I just don't use it.

 

I've also noticed another bug on the forum, which is the subforum icons on the board index not updating properly when you just hit the back button after finishing reading a thread. You have to click on the subforum of the thread, and then click your way to the board index thereafter, before the subforum icons will stop showing as \"unread.\" You can't just use the back button in your browser. No, refreshing doesn't help.

I've noticed this as well, actually (I don't use View New Posts, though, so I can't comment on that).

 

I'm writing it off as invisionfree being shitty software :lol:

 

Seriously though, I'll look into it.

Share this post


Link to post
Share on other sites
Guest
I've noticed this, too. Only works half the time. I just don't use it.

 

I've also noticed another bug on the forum, which is the subforum icons on the board index not updating properly when you just hit the back button after finishing reading a thread. You have to click on the subforum of the thread, and then click your way to the board index thereafter, before the subforum icons will stop showing as \"unread.\" You can't just use the back button in your browser. No, refreshing doesn't help.

I've noticed this as well, actually (I don't use View New Posts, though, so I can't comment on that).

 

I'm writing it off as invisionfree being shitty software :lol:

 

Seriously though, I'll look into it.

Why are you not hosting this locally on your server and using some better software?

Guests/Anonymous users can't even see "View New Posts". You should try SMF(Simple Machines), it's open source/free.

 

If hosting locally isn't an option, they better allow you to have a database backup, otherwise you'll be dependent on them.

Share this post


Link to post
Share on other sites
Why are you not hosting this locally on your server and using some better software?

Guests/Anonymous users can't even see \"View New Posts\". You should try SMF(Simple Machines), it's open source/free.

 

If hosting locally isn't an option, they better allow you to have a database backup, otherwise you'll be dependent on them.

I'm not hosting locally because my server can't afford it. Heck, it doesn't even have PHP/MySQL, nor do I intend to add it.

 

I went with IF because they're reputable/reliable (in regards to server usage, etc) and allows free DNS handling (so I can have forum.tulpa.info). I could get a copy of the database if I wanted to convert/move to somewhere else in the future, though the community is small enough right now that using invisionfree isn't much of an issue for that. I'd probably upgrade to some sort of paid/dedicated host for a forum if the site got big enough to require one.

Share this post


Link to post
Share on other sites

I'm now having an issue where I'll go into a subforum that had posts I've yet to see (as indicated by the lit up 'ipb' thing), but no topics will have a lit up envelope. This happens even if I haven't seen posts within some of those topics, but the kicker is that it doesn't mess up all of the time.

Share this post


Link to post
Share on other sites
I'm now having an issue where I'll go into a subforum that had posts I've yet to see (as indicated by the lit up 'ipb' thing)' date=' but no topics will have a lit up envelope. This happens even if I haven't seen posts within some of those topics, but the kicker is that it doesn't mess up all of the time.[/quote']I think you're having the same problem that I described.

Share this post


Link to post
Share on other sites
I think you're having the same problem that I described.

Nope. I had the problem you described earlier, but this one has effectively replaced it. Which sucks, because as opposed to just having to re-navigate to boards, I've now got to look through many individual topics to make sure I've not already read through them. It's far more annoying.

Share this post


Link to post
Share on other sites

Topics that are new should have a little blue box next to them (ignoring the "ipb" box on the main board).

 

What I've been doing, is if I see a board with unread posts (ipb is lit up), I go in there, read the topics with little blue boxes next to them, then afterwards click the "ipb" box to "unlight" it.

 

Or, do you mean that you're not even seeing the little blue box next to new topics?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.