Pleeb

SSL hiccups

Recommended Posts

Hello tulpa.info,

 

You might be receiving SSL warnings or notice other weird things happening; long story short, our certificate expired; I've renewed it, and I'm working on getting everything back on track.

Share this post


Link to post
Share on other sites

HA! I fixed it!

 

Basically, the certificate expired so I decided to generate a new certificate. However, I was thinking about it, and decided to try something else. We used to use Cloudflare for the longest time, and have always loved it because it speeds up the site and saves on bandwidth. Unfortunately, Cloudflare doesn't play nice with SSL unless things are configured a specific way.

 

To make a long story short, cloudflare didn't see the SSL, and tried to redirect it to https. MyBB thought it was supposed to be https, so it tried redirecting itself to https... The end result was a 301 redirect from https://community.tulpa.info to https://community.tulpa.info For all you non-tech guys out there, it means that we got thrown into an infinite loop that crashed everything. I found the solution on this site and modified the GoogleSEO plugin accordingly.

 

Now we have SSL and Cloudflare!

Share this post


Link to post
Share on other sites

I've had some weird things happening these past few days. It's still going on. Not sure if this is the same issue or not though.

 

Anyway, well, let me take a screenshot. The theme isn't displaying correctly, which is just mildly annoying. The more inconvenient thing is that periodically my browser gives me the error message: "Unable to complete secure transaction", and I have to manually change "https" to "http" to get the page to load.

 

This seems to only happen with Opera -- Firefox and Explorer (I think) display the site correctly. I think the default browser on my Android S4 was giving me trouble earlier, but it seems to be working flawlessly now, so perhaps I'm mistaken.


"Some things have to be believed to be seen." - Ralph Hodgson

Share this post


Link to post
Share on other sites

I've had some weird things happening these past few days. It's still going on. Not sure if this is the same issue or not though.

 

Anyway, well, let me take a screenshot. The theme isn't displaying correctly, which is just mildly annoying. The more inconvenient thing is that periodically my browser gives me the error message: "Unable to complete secure transaction", and I have to manually change "https" to "http" to get the page to load.

 

This seems to only happen with Opera -- Firefox and Explorer (I think) display the site correctly. I think the default browser on my Android S4 was giving me trouble earlier, but it seems to be working flawlessly now, so perhaps I'm mistaken.

I think it seems to be a cached thing, in which case it should resolve itself soon. I just installed Opera and tried it on my computer, and it looked normal. Try clearing your browser cache and see if it fixes the problem.

Share this post


Link to post
Share on other sites

Browser cache doesn't seem to be doing anything for it. It must be because I'm on an old version of Opera: 11.62.


"Some things have to be believed to be seen." - Ralph Hodgson

Share this post


Link to post
Share on other sites

Does a newer browser work for you? And does Opera 11.62 mess up other sites in a similar way sometimes? If not, I blame Cloudflare -- It's either mis-caching something or a connection isn't getting through.


Lyra: human female, ~17

Evan: boy, ~14, was an Eevee

Anera: anime-style girl, ~12; Lyra made her

My blog :: Time expectations are bad (forcing time targets are good though)

Share this post


Link to post
Share on other sites

This is the only site that had given me that trouble, and only this last week or so. But yeah, if I'm the only one having trouble, I can get a new browser.


"Some things have to be believed to be seen." - Ralph Hodgson

Share this post


Link to post
Share on other sites

This is what I'm staring at.

 

https://gyazo.com/9a965858fe1f2baa230bfa7bdf479ce8

 

https://gyazo.com/866e684f48d0d2284e97d5138f8fac87

 

Don't think that's normal...


Current: Rainbow Dash & Ruby the Dolphin

 

LINK to the story of my Wonderland.

 

The story is the product of 16 years of stress, tension, etc, and is uncensored, read at your own risk.

Share this post


Link to post
Share on other sites

That's the same as for me. What version of Chrome is that?


"Some things have to be believed to be seen." - Ralph Hodgson

Share this post


Link to post
Share on other sites

How do you check?


Current: Rainbow Dash & Ruby the Dolphin

 

LINK to the story of my Wonderland.

 

The story is the product of 16 years of stress, tension, etc, and is uncensored, read at your own risk.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.